Slow connections issues

Incident Report for Tilkee

Resolved

This incident has been resolved.
Posted Apr 17, 2018 - 15:16 CEST

Investigating

Slow connections issues - We are investigating to fix this.
Posted Apr 17, 2018 - 14:56 CEST