eSignature delayed
Incident Report for Tilkee
Postmortem

Some eSignature has been delayed, resulting in some customer experiencing error message at the end of the signature process.
Every signature is correctly registered in the system.

Posted May 29, 2019 - 15:31 CEST

Resolved
eSignature process is slowed down
Posted May 28, 2019 - 14:30 CEST